FeatherBB

Lighter than a feather.

You are not logged in.

#1 2016-02-22 20:23:07

Putte
Member
Registered: 2015-09-08
Posts: 18

An issue with non-ascii characters in the message text

It seems that there is some sort of filtering/encoding problem with the Beta-4 version when the message text contains non-ascii characters like e.g. the Scandinavian æøå. When the text contains æøå a piece of the text, apparently corresponding to the number of non-ascii charcters in the text, is cut off at the end of the text before the text is stored in the DB. See below.

Without non-ascii characters:

A signature is a small piece of text that is attached to your posts. In it, you can enter just about anything you like. Perhaps you would like to enter your favourite quote or your star sign. It's up to you! In your signature you can use BBCode if it is allowed in this particular forum.

With æøå a chunk of the text is cut off at the end of the message and becomes:

A signature is a small piece of text that is attached to your posts. In it, you can enter just about anything you like. Perhaps you would like to enter your favourite quote or your star sign. It's up to you! In your øæå signature you can use BBCode if it is allowed in this particular for

I'm using MySQL with UTF-8 collat

Offline

#2 2016-02-22 20:27:23

Putte
Member
Registered: 2015-09-08
Posts: 18

Re: An issue with non-ascii characters in the message text

I can see now that you have the same problem here on the official forum, as the last part of my message is missing...

Putte

Offline

#3 2016-02-22 21:14:24

adaur
Lead developer
From: France
Registered: 2015-06-05
Posts: 94
Website

Re: An issue with non-ascii characters in the message text

Good catch. It doesn't happen with the latest FluxBB, I will try to find what is causing it and come back to you.

adaur

Offline

#4 2016-02-22 21:24:19

adaur
Lead developer
From: France
Registered: 2015-06-05
Posts: 94
Website

Re: An issue with non-ascii characters in the message text

Offline

#5 2016-02-22 22:17:44

Putte
Member
Registered: 2015-09-08
Posts: 18

Re: An issue with non-ascii characters in the message text

Yes, your patch seem to have solved the issue. Smile

Putte

Offline

Board footer

[ Generated in 0.066278 seconds, 8 queries executed - Memory usage: 1.42 MiB (Peak: 1.46 MiB) ]